Problem with adding a user

Open discussion about our Alloy Navigator 5 application

Problem with adding a user

Postby ap-prelec on Wed May 02, 2007 7:43 am

I have a "problem" when trying to create a user with Windows authentication in the administration tool. It goes fine until the very end, where it comes up with the following message:
"The login already has an account under a different user name".

And it is true that the user has been created before, but deleted again.
Is the any way to either see or completely delete these traces or what it is from the earlier creation, so it can be recreated.

Thanks
ap-prelec
Newbie
 
Posts: 1
Joined: Mon Mar 13, 2006 11:15 am

Postby pille on Wed May 02, 2007 12:10 pm

Welcome ap-prelec :D

I've seen situations where the application doesn't refresh properly either because of options or a slow connection to SQL so the application still thinks the account exists.

I would delete the account, make sure that no other accounts exist with the login you'll be using and then restart both the administrative settings and the A5 application, if open, on your machine.

Then try to create the account in question.
Contact Technical Services directly:
support@alloy-software.com
http://support.alloy-software.com

Paul Ille
Alloy Software
Maximize your IT Universe
Follow us on Twitter: http://twitter.com/alloysoftware
Image
User avatar
pille
Alloy Software
 
Posts: 473
Joined: Thu Aug 11, 2005 3:11 pm
Location: New Jersey, USA

Postby prelectronics on Thu May 03, 2007 2:29 am

Hi,

I am working with AP on this problem
I have check our Account this morning, we only have 4 so I am sure there is no trace in the accounts of the user we want to create again.
And we still get the same error.
Just a note we are using windows auth if that has any thing so say on this matter
prelectronics
Newbie
 
Posts: 1
Joined: Wed Aug 18, 2004 5:06 am

Postby pille on Thu May 03, 2007 2:50 pm

Welcome prelectronics :D

prelectronics wrote:And we still get the same error.


What I would do at this point is check to see if the account still exists on the SQL side. Maybe it's being hung up by something that remains there for whatever reason.

I would open up Enterprise Manager or Studio Express and see if the user in question still exists there.

Two places to check:
SQL Server - Security > Logins
Database - Database > [databasename] > Security > Users

If the person exists there, and they don't have rights to anything on the SQL server, just delete them. If they do have rights, of course make sure you note them before deleting so you can reconfigure them afterwards.

Let me know how that goes.
Contact Technical Services directly:
support@alloy-software.com
http://support.alloy-software.com

Paul Ille
Alloy Software
Maximize your IT Universe
Follow us on Twitter: http://twitter.com/alloysoftware
Image
User avatar
pille
Alloy Software
 
Posts: 473
Joined: Thu Aug 11, 2005 3:11 pm
Location: New Jersey, USA


Return to Alloy Navigator 5 Discussion

Who is online

Users browsing this forum: No registered users and 1 guest