Make SelfServiceDesk fields mandatory

Open discussion about our Alloy Navigator 5 application

Make SelfServiceDesk fields mandatory

Postby jean12345 on Thu Apr 05, 2007 7:29 am

Hi,

how can i Make SelfServiceDesk fields mandatory?

Thnx
jean12345
Junior
 
Posts: 3
Joined: Thu Apr 05, 2007 7:22 am

Postby pille on Fri Apr 06, 2007 10:56 am

Hi Jean :)

There's a couple ways to do this actually. You can go into the admin settings under the module's field section (for instance: admin settings > service support > incident management > fields) and double click the field you want to make mandatory, then check off field is mandatory

or

Create a business rule that works on save where the criteria is (field you want to have required) is blank and the action is a message box of error type. You can make it popup whatever message you want, but people won't be able to save it unless the field is not blank.

Be careful with making fields mandatory though. You'll want to consider that the self service portal doesn't allow users to see all fields. If you make a field mandatory that they can't fill then end users won't be able to submit tickets.

My response is based on version 5.2.
Contact Technical Services directly:
support@alloy-software.com
http://support.alloy-software.com

Paul Ille
Alloy Software
Maximize your IT Universe
Follow us on Twitter: http://twitter.com/alloysoftware
Image
User avatar
pille
Alloy Software
 
Posts: 473
Joined: Thu Aug 11, 2005 3:11 pm
Location: New Jersey, USA

Postby jean12345 on Thu Apr 12, 2007 8:49 am

Hi,

we are using 5.1.4 build 312.

I cannot seem to find the mandatory checkbox. When i go to administrative settings to the field for incidents, when i double click on the field i can only give it a new label.

Or is this not available in our version?
Can i upgrade to 5.2?

Regards,

Jean
jean12345
Junior
 
Posts: 3
Joined: Thu Apr 05, 2007 7:22 am

Postby pille on Thu Apr 12, 2007 9:37 am

In 5.1.x you would have to use business logic to achieve what you're looking to do since the other option is only available in 5.2

jean12345 wrote:Can i upgrade to 5.2?


If your company has a maintenence contract then you have access to all versions within the 5.x version. All you have to do is have the registered user (person who's name is on the license) log in to the support portal and they can download the updated installations files.

I'd recommend upgrading to 5.2 since it really improves upon the 5.1.x version. Documentation like what's new, etc is on the support portal as well.
Contact Technical Services directly:
support@alloy-software.com
http://support.alloy-software.com

Paul Ille
Alloy Software
Maximize your IT Universe
Follow us on Twitter: http://twitter.com/alloysoftware
Image
User avatar
pille
Alloy Software
 
Posts: 473
Joined: Thu Aug 11, 2005 3:11 pm
Location: New Jersey, USA


Return to Alloy Navigator 5 Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron