Satisfaction Survey Email

Open discussion about the Alloy Navigator Express 6 application

Satisfaction Survey Email

Postby Jethroz on Tue Aug 20, 2013 2:36 pm

Trying to find a way to place a direct link in the satisfaction survey that will go directly to the relevant ticket in the SSP. I don't see a way to have the ticket ID added to the end of the link.

http://server/HelpDesk/Tickets/TicketView/c6adfb7f-7dbb-480e-9690-8d3c552d8afb

Example:
Code: Select all
Please rate your experience with the support you received on %[Ticket]% by clicking the link below.

http://server/HelpDesk/Tickets/TicketView/{ID} <--?!!!

Ticket Summary:
%[Summary]%


How do I get the system to automatically add the bolded ticket ID above to a link in an email message? It would be nice to have the user just click the link and be taken directly to their ticket, rather than the main page and have them sort through to find the one to rate.
Jethroz
Junior
 
Posts: 7
Joined: Wed Sep 28, 2011 9:29 am

Re: Satisfaction Survey Email

Postby eliaslynch on Mon Aug 26, 2013 11:06 am

In the enterprise version I'm pretty sure the link is like this:

http://servername/selfserviceportalname/Go/ticketnumber

I'm guessing it's the same for this product.
--------
Elias
User avatar
eliaslynch
Senior
 
Posts: 212
Joined: Wed Jul 09, 2008 7:03 pm

Re: Satisfaction Survey Email

Postby Jethroz on Mon Aug 26, 2013 11:56 am

eliaslynch wrote:In the enterprise version I'm pretty sure the link is like this:

http://servername/selfserviceportalname/Go/ticketnumber

I'm guessing it's the same for this product.


Yes, that is basically what I need. Your suggested link style still doesn't work.

http://server/HelpDesk/Go/T000337 returns,
"No object with the "T000337" ID has been found. Please check the ID you entered."

Might be on the right path. It still appears that it is wanting the ID string rather than the actual ticket number though.

To clarify, I would like to know if a placeholder exists for the following:
%[Ticket]% - returns T000337
%[?????????]% - returns c6adfb7f-7dbb-480e-9690-8d3c552d8afb
:?
Jethroz
Junior
 
Posts: 7
Joined: Wed Sep 28, 2011 9:29 am

Re: Satisfaction Survey Email

Postby janstonselig on Wed Aug 28, 2013 10:16 am

Are you using 6.6?

I just tested the link the way Elias posted it and it worked for me in 6.6.

I did 'localhost/HelpDesk/Go/T12992' from the server and it worked. After it brings me to the ticket, it does change the url to something else with what looks like the ID.
User avatar
janstonselig
Senior
 
Posts: 174
Joined: Thu Aug 30, 2007 1:12 pm


Return to Alloy Navigator Express 6 Discussion

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest

cron