Page 1 of 1

Adding Related_CI_Name var creates blank report

PostPosted: Wed Apr 27, 2011 5:04 pm
by rcs-tech
I am trying to edit Incident List to include Related_CI_Name so i can view incidents created in a specific date range by tracked software name.

I edited the following:

\\db expert -> command
UNION
SELECT DISTINCT 'Related_CI_Name.'+IsNull(Related_CI_Name,' No Related_CI_Name') 'Value','Related_CI_Name' 'Group_Name'
FROM Incident_List

\\DynamicField2 -> Select {@ParentGroup}

Case "Related_CI_Name":
{Incident_List.Requester}

\\DynamicField3
Case "Related_CI_Name":
{Incident_List.Status}

\\DynamicGrouping1 -> Select {@ParentGroup}
Case "Related_CI_Name":
If {Incident_List.Related_CI_Name}="" Then "No Related CI Names Found"
Else {Incident_List.Related_CI_Name}

\\DynamicLabel2 -> Select {@ParentGroup}
Case "Related_CI_Name":
UpperCase("Requester")

\\DynamicLabel3 -> Select {@ParentGroup}
Case "Related_CI_Name" :
UpperCase("Status")

The report is able to run without any error but the report apart from the report header is blank. I even created test incident with specific related ci but report is blank.

Thanks :?

Re: Adding Related_CI_Name var creates blank report

PostPosted: Tue May 03, 2011 10:49 pm
by surint
I would check SQL account you trying to run report under. Incident_List view is secured, so account should be registered in the Navigator and has permissions to view Incidents. If account is not in the technician account list then Incident_List view returns no incidents.

Re: Adding Related_CI_Name var creates blank report

PostPosted: Thu May 05, 2011 6:05 pm
by rcs-tech
I am using my technician account which has access to incidents list. When i ran the original report w/o modification, it runs and report populates. But when i added the entry, the report does not like being grouped by related ci name.

Trying to make a report that gives all ticket for a date range by tracked sofware name so i used the related ci to pull the names for tracked software list but the report keep returning blanks.

Thanks for the help

Re: Adding Related_CI_Name var creates blank report

PostPosted: Wed May 11, 2011 10:54 am
by janstonselig
I admit I haven't looked through all of what you have here, but could it be because of the joins and the fact that some related_ci fields are blank? Just a quick guess.

Re: Adding Related_CI_Name var creates blank report

PostPosted: Tue May 17, 2011 5:19 pm
by rcs-tech
yeah. i thought so too and created some test incident with a valid related ci name for a specified date range which also brought back a blank report.

would you know the permission that i would need to have enabled to give full access to database for report creation by related ci name?

Re: Adding Related_CI_Name var creates blank report

PostPosted: Fri May 20, 2011 10:23 am
by tccwrd
rcs-tech wrote:would you know the permission that i would need to have enabled to give full access to database for report creation by related ci name?


Not sure, but given that sysadmin is the highest permission maybe give that and see if it at least solves the issue. It might not be that.