Page 1 of 1

Audit runs every time unless user has admin / local admin ri

PostPosted: Mon Dec 13, 2004 7:54 pm
by glipschitz
Well I have this quirky problem where if the user doesnt have Local Admin rights or Domain Admin rights, the program seems to run every time they log on, even tho the file is set to a monthly run schedule.

I really don't want to give my users local admin rights because then they play with things. And it doesnt seem to like it even when they have Power User rights. So I am now stumped...

We are running a Windows 2003 Small Business Server, and XP Professional with SP 2 desktops/laptops in a pure Dell environment.

Any suggestions??

Greg

PostPosted: Tue Dec 14, 2004 11:50 am
by mhull
ina32.exe needs write/modify permissions to either %systemroot% or c:ina32 in order to record last audit date for scheduling purposes.

PostPosted: Mon Dec 20, 2004 7:31 pm
by glipschitz
And how do I easily go about doing this without mucking around too much.... I have had a play with a bit of scripting, but have done my head in with that.

Any ideas / hints or pre written scripts??

Greg

PostPosted: Tue Dec 21, 2004 5:30 pm
by mhull
'mkdir c:ina32' is the first thing to try. Of course, maybe this doesn't create the folder with sufficient permissions. Then you need a way of setting NT ACL's through command line. I'm not familiar with any native Windows method for this. There are programs like the following which would theoretically be useful for this:

http://www.helge.mynetcologne.de/setacl/

Of course, Alloy Software doesn't endorse the above program or guarantee it won't cause issues such as data loss, downtime, grevious bodily harm, etc. But it looks like it might come in handy.

PostPosted: Fri Jan 07, 2005 7:44 am
by fschnell
Windows (at least 2000) has a commandline tool named CACLS.EXE which can be used to set access rights. Not sure, it may come out of the resource kit.

PostPosted: Fri Jan 14, 2005 1:37 pm
by aszbikowski
If you're running in an Active Directory enviroment you can create and set permissions on the local computers via Group Policy. Edit your computer policy...

User Computer Configuration > Windows Settings > Security Settings > File System.

Right Click on File System, select Add File. Follow the wizzard, creating the folder on your local drive if needed. In the end, you should have %SystemDrive%ina32 in there.

The folder still has to be created before permissions will be applied, but creating the folder is easy enough to do with a machine startup script (Again something that only works on Windows 2000 and XP...)

PostPosted: Fri Jan 28, 2005 6:22 pm
by glipschitz
Have created the INA32 Directory on everyones pc and used Active Directory to set the permissions, but it still seems to be looking for %systemroot% rather than ina32 directory to store the files in.

Any way to make it default to the C:ina32 dir?

Greg

PostPosted: Fri Feb 04, 2005 7:13 pm
by mhull
It will go to c:ina32, as long as ina32.ini does not exist in systemroot, and the user doesn't have the ability to create it. Make sure that ina32.ini does not exist. Keep in mind that it is a hidden/system file and running 'attrib /S ina32.ini' from a c:> DOS prompt is the best way to find it.

If you still have trouble it probably indicates some combination of directory permissions we haven't seen before. In that case please email support@alloy-software.com with reference to forum ID 3087 so we can get more details about your environment.

PostPosted: Wed Feb 09, 2005 5:43 pm
by LloydSev
It is also possible to apply permissions to JUST the ina32.ini file.. that would seem to be the more practical approach instead of setting up an entire directory where users have just about full control over.

PostPosted: Wed Feb 16, 2005 2:55 am
by mhull
That will work fine as well. Feel free to use whatever method suits your organization's policies and needs best.

PostPosted: Tue Mar 01, 2005 11:57 pm
by dwaynel
OK, it is running everytime in our organisation regardless if users are administrators or not. The users all have Full Control over their c:windows and the c:windowsina32.ini file.

Here's my ina32.cfg

[Options]
ConfigID=258A3321-BD4A-4B4A-954C-366C86FEF442
Version=4.2.0
Path=\\basntfp054assetnavigator
DataPath=\\basntfp054assetnavigatorAuditData
LogPath=\\basntfp054assetnavigatorLog
NoScan=1
StrictSchedule=0
ModeInteractive=0
ModeSilent=1
ModeInteractiveOnce=0
EnableCancel=0
EnableSaveTo=0
ShowUserName=0
ShowEMail=0
ShowProgress=0
AT_AssetTag=0
AT_SerialNumber=0
AT_ComputerName=1
AT_Manual=0
AT_Smart=0
EditAssetTag=0
EL_Period=0
EL_App=0
EL_Security=0
EL_System=0
EL_Error=0
EL_Warning=0
EL_Info=0
InventorySchedule=BiWeekly
FileScanSchedule=Monthly
AllHardDisks=0
NoWindowsDir=1
NoBrowserCache=1
Profile=Find PST's
EL_SuccessAudit=0
EL_FailureAudit=0
[Message]
Count=3
Item0=Your network administrator has requested an audit of this computer.
Item1=Please wait until the audit finishes. You will be able to continue your work shortly.
Item2=Thank you.
[ExcludedMachines]
Count=5
Item0=BAS*
Item1=CARNT*
Item2=DARNT*
Item3=TOONT*
Item4=UNLNT*
[Bypass]
Count=1
Item0=wfiadmin
[WMIFilter]
Count=10
Item0=Chassis Serial Number
Item1=Eval
Item2=N/A
Item3=No Asset Information
Item4=No Asset Tag
Item5=No Enclosure
Item6=None
Item7=Not Available
Item8=System Manufacturer
Item9=System Name
[RegistryKeys]
Count=1
[CustomFields]
Count=0
Caption=" Additional Information "
[RegistryKey0]
RegKey=HKEY_LOCAL_MACHINE
RegPath=SYSTEMSetup
RegValue=OEMDuplicatorString
Section=Custom
Key=SOE_Version
Label=SOE
[FilesSummary]
PST=
[Directories]
C:=


Would love to know what I'm doing wrong - have tried both 4.4.1.970 and 4.3.2.925 versions of ina32.exe

Thanks

Dwayne

PostPosted: Fri Apr 29, 2005 2:23 pm
by condabas
"StrictSchedule=0"

Change this to "StrictSchedule=1"