Using Windows Authentication to login to the site.

Open discussion about the Asset Navigator Web HelpDesk

Using Windows Authentication to login to the site.

Postby bakkebob on Thu Feb 26, 2004 10:14 pm

I have read a few other forum posts, but they were not quite clear as to any real solution for us.

Our setup is as follows:
AN 4.24 Enterprise
Windows 2003 Server, Exchange 2003 and IIS 6.0 on the same server.
MS Sql 2000 Server is a standalone server.

I want to enable windows authentication, but I have read that this is not possible with my current configuration, unless I host IIS and SQL on the same server, which we cannot do.

Has anyone gotten windows authentication to work with an sql server on a separate machine? Bottom Line is I am trying to get buy-in to use the web-based system but this is going to be quite an inconvenience for them if they have to have yet another password.

Thanks for your help
Brian
bakkebob
Junior
 
Posts: 4
Joined: Mon Feb 23, 2004 3:35 pm

Update-Using the internet guest account

Postby bakkebob on Thu Feb 26, 2004 10:24 pm

Okay, so I guess I could possibly use the Internet Guest Account? But of course there is no way to select the user. Has someone modified the NewTicket.asp to pull in their users and thus get around this problem?

Thanks all for your help!

Brian
bakkebob
Junior
 
Posts: 4
Joined: Mon Feb 23, 2004 3:35 pm

Update-solved the Problem

Postby bakkebob on Fri Feb 27, 2004 6:11 pm

I will post for others who run into this problem.
First and foremost let me clarify what we were trying to do:

We wanted to use Windows Authentication to log our end-users into the user help desk with Sql Impersonation. What this means is you want people to login through windows domain accounts to the help desk website, but you will always use the same SQL user to connect to your SQL backend.

With this in mind, we modified the two lines in global.asa to look like this below:

Session("Impersonation")=UCase("Basic")
Session("Authentication")=UCase("Windows")

Next, disable anonymous access to the helpdesk under IIS.
{Go into IIS find the helpdesk website, right click and choose properties, choose directory security and click the first edit button, for enabling anonymous access. Then uncheck the first checkbox for anonymous access. Also, make sure integrated windows authentication is checked}

*Important step--Make sure your users are in Asset Manager Contacts and make sure you do not change the ‘Name’ field under the general tab of each contact(user.) For some reason, if we change the ‘Name’ field then authentication doesn't work properly?

--Finally another important thing to know is if your internal webserver is set up with DNS and looks like this: http://www.webservername.com/helpdesk/ as ours is your end-users will get a authentication dialog box to logon to the helpdesk. There are two ways to avoid this:
1. Have your end-users link right to the http://webservername/helpdesk/.
2. Setup Internet explorer to see your site: http://www.webservername.com/helpdesk/ as a local intranet site. To do this go into Internet Explorer, Choose tools, internet options, security tab. Choose local intranet, click sites, then click advanced, then add your site. Click okay. This should work for you.

Sorry for the lengthy step-by-step response, just hope it saves someone elses time in the future.

Brian
bakkebob
Junior
 
Posts: 4
Joined: Mon Feb 23, 2004 3:35 pm


Return to Asset Navigator 4 Web HelpDesk Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron