Microsoft Jet database engine error...

Open discussion about the Asset Navigator Web HelpDesk

Microsoft Jet database engine error...

Postby hbc7172 on Tue Jan 13, 2004 6:12 am

Asset Navigator 4.2

I am able to connect to and login to the web help desk no problem from the machine that physically contains the database files. Same machine that is running IIS.

When any other machine attempts to connect via the web helpdesk they receive the following error:

The Microsoft Jet database engine cannot open the file ''. It is already opened exclusively by another user, or you need permission to view its data

Here is my global.asa file. Please point out any problems you might see that are causing this problem.

*
-->

<SCRIPT LANGUAGE="VBScript" RUNAT="Server">
Sub Session_OnStart
'---------------------------------------------
' Impersonation type valid value "Off", "Basic"
'---------------------------------------------
Session("Impersonation")="OFF"

'---------------------------------------------
' Authentication type valid value "Standard"
'---------------------------------------------
Session("Authentication")="STANDARD"

'---------------------------------------------
' Authorization user for WEB only
'---------------------------------------------
Session("DBLogin")=""
Session("DBPassword")=""

'---------------------------------------------
' Predefined E-Mail
'---------------------------------------------
' Session("SendRegistrationTo")=""

'---------------------------------------------
' ACCESS Parameters
'---------------------------------------------
Session("DataBase")="\\KNAUS00017151AdminITAdminHQ.mdb"

'---------------------------------------------
' Mail Setting
'---------------------------------------------
Session("SMTPHost")="smtp.your-organization.com"
Session("SMTPPort")=25

'---------------------------------------------
' Page Size
'---------------------------------------------
Session("PageSize")=4

Session("ShowAllTickets")=false
Session("USADateFormat")=true
Session("ShowDueDate")=true

'---------------------------------------------
' Location of optional files
'---------------------------------------------
Session("TmplDir")="template"
Session("ImageDir")="Images"

'---------------------------------------------
' Logo setting
'---------------------------------------------
Session("Logo.Img")="alloy.png"
Session("Logo.URL")="http://www.alloy-software.com"

'---------------------------------------------
' Color of statuses
'---------------------------------------------
Session("ColorStatus")=true ' True - use status color
Session("Unassigned.Color")="#FFC4C4"
Session("Assigned.Color")="#DDF4FF"
Session("Closed.Color")="FFFFD7"
Session("Resolved.Color")="CCF2DB"

'-------------------------------------------------
' Please don't edit these variables
'-------------------------------------------------
Session("PageNo")=1
Session("SortColumn")="Ticket"
Session("LoginRedirect")="default.asp"

end sub

Sub Session_OnEnd
end sub
</SCRIPT>
hbc7172
Newbie
 
Posts: 1
Joined: Thu Jan 01, 2004 3:47 am

Postby mhull on Tue Jan 13, 2004 12:02 pm

Standard and Off is not a valid impersonation type. You need to do Standard+Basic. Also, you need to create a new DB Technician user in User management in the Administrator role, and put his credentials in to the DBLogin/DBPassword parameters in global.asa.
mhull
 


Return to Asset Navigator 4 Web HelpDesk Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron