Windows 2003 Server & IIS

Open discussion about the Asset Navigator Web HelpDesk

Windows 2003 Server & IIS

Postby esamatti on Mon Dec 15, 2003 12:33 pm

Has anyone had any luck with getting Web Help Desk to work with a default installation of Windows 2003 and the IIS that comes with it?

After installing it exactly the way I did with Windows 2000 Server I get the following error when I try to browse to http://server/techhelpdesk

It doesn't even try to bring it up.

***********************************************************
The page cannot be displayed
There is a problem with the page you are trying to reach and it cannot be displayed.

--------------------------------------------------------------------------------

Please try the following:

Open the tcnetwork home page, and then look for links to the information you want.
Click the Refresh button, or try again later.

Click Search to look for information on the Internet.
You can also see a list of related sites.

HTTP 500 - Internal server error
Internet Explorer
***********************************************************
esamatti
Senior
 
Posts: 41
Joined: Wed Aug 13, 2003 11:04 am

Postby mhull on Mon Dec 15, 2003 2:06 pm

This error message is vague, but you can get a more informative one by disabling 'friendly HTTP error messages' in your web browser options.

Note that if your Windows 2003 machine really was installed with all defaults, .ASP is not installed or enabled. You need to install and enable it to run our .ASP application.
mhull
 

Postby esamatti on Mon Dec 15, 2003 2:07 pm

Ah that maybe it. Let see if I can figure out how to do that. Thanks!
esamatti
Senior
 
Posts: 41
Joined: Wed Aug 13, 2003 11:04 am

Postby esamatti on Mon Dec 15, 2003 2:20 pm

Well, I guess I did install ASP during IIS installation. So, it's not that. Dangit!
esamatti
Senior
 
Posts: 41
Joined: Wed Aug 13, 2003 11:04 am

Postby mhull on Mon Dec 15, 2003 2:51 pm

No, .ASP is not installed alongside IIS automatically, so if you 'guess' you installed it, I doubt if it is there. Please refer to IIS documentation for steps on enabling .ASP.
mhull
 

Postby esamatti on Mon Dec 15, 2003 3:15 pm

By "I guess I installed it" means "I did install it, but I didn't remember I did" until I checked it when you suggested it.

The bottom line is .ASP is installed, and still no dice.
esamatti
Senior
 
Posts: 41
Joined: Wed Aug 13, 2003 11:04 am

Postby esamatti on Mon Dec 15, 2003 3:18 pm

And it can be installed during installation. At this point during installation I checked both boxes. Unless this isn't what you are talking about, in which case I'll have to look into it again.

Image
esamatti
Senior
 
Posts: 41
Joined: Wed Aug 13, 2003 11:04 am

Postby mhull on Mon Dec 15, 2003 3:26 pm

Until you post the error message you get after turning off 'friendly' errors as I suggested above, it's hard to say.
mhull
 

Postby esamatti on Mon Dec 15, 2003 3:32 pm

Ok, ok! Here you go.

Microsoft VBScript runtime error '800a01f4'

Variable is undefined: 'Session'

/techhelpdesk/include/tools.asp, line 438
esamatti
Senior
 
Posts: 41
Joined: Wed Aug 13, 2003 11:04 am

Postby mhull on Mon Dec 15, 2003 5:36 pm

This indicates that session state is turned off in the app options for your help desk virtual directory.
mhull
 

Postby esamatti on Tue Dec 16, 2003 3:35 pm

Sweet! Thanks works like a charm now after enabling Session state.

So, for anyone else that runs into this:

If you are using Windows 2003 Server

1.) Make sure .ASP is enabled for IIS.
a.) Either enable during the IIS setup, or afterwards in add/remove soft

After installing Web HelpDesk

2.) Turn session state on on the application.
b.) For the application (HelpDesk for instance) Properties->Virtual Directory/Application Settings->Configure->Options.

Thank again for the help mhull.
esamatti
Senior
 
Posts: 41
Joined: Wed Aug 13, 2003 11:04 am


Return to Asset Navigator 4 Web HelpDesk Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron