login problems

Open discussion about our Asset Navigator application

login problems

Postby kagtech on Mon Jun 21, 2004 9:57 am

I have the enterprise edition running on a sql server and the web helpdesk also running. I can use nt authentication to login to the db but when I try to use the same account for the web I get invalid username or password.
kagtech
Senior
 
Posts: 29
Joined: Thu Apr 22, 2004 12:02 pm

Postby kagtech on Mon Jun 21, 2004 10:03 am

I changed the web to windows login and now when I go to the page I get

Error: Login failed for user 'NT AuthorityAnonymous Logon'
kagtech
Senior
 
Posts: 29
Joined: Thu Apr 22, 2004 12:02 pm

Postby kagtech on Mon Jun 21, 2004 10:18 am

Ok I can make it work but only with one user. If I got to the properties of my webpage and look at security and authentication methods. The default iusr gives the error from the second post. If I look in the right hand corner of web access I don't have a user name. If I got to authentication method and choose Anonymous Access and choose the user I want then I can login as that user but only that user.
kagtech
Senior
 
Posts: 29
Joined: Thu Apr 22, 2004 12:02 pm

Postby Isaev on Mon Jun 21, 2004 11:04 am

This is standard trouble of MS. If you have WEB and SQL server locateted in DIFFERENT machine you have this message. Please use IMPERSONATE not OFF or move you WEB to SQL machine.
Isaev
Member
 
Posts: 22
Joined: Sun May 05, 2002 4:37 am

Postby kagtech on Mon Jun 21, 2004 11:36 am

How do I use IMPERSONATE? Iwould like to avoid setting them up on the same machine
kagtech
Senior
 
Posts: 29
Joined: Thu Apr 22, 2004 12:02 pm

Postby Isaev on Mon Jun 21, 2004 11:56 am

Please edit your GLOBAL.ASA or run WebCfg and set level of imperonate.
Isaev
Member
 
Posts: 22
Joined: Sun May 05, 2002 4:37 am

Postby mhull on Mon Jun 21, 2004 12:10 pm

The web interface installation guide contains details on the procedures which Isaev described. It is very important to read it before attempting web interface configuration, as it will detail what settings to use according to your environment.
mhull
 


Return to Asset Navigator 4 Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron